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Note on PDF Manual
This PDF is generated from the online Aspen User Manual at AspenDocs
(https://ncar.github.io/aspendocs/). The full text of this manual, as well as more
detailed information about the QC algorithms and formulas Aspen uses, are
available on the AspenDocs site.
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Introduction
Want to give Aspen a test drive? It comes with sample data
files, located in the Sample Data/ directory (found below the
Aspen installation directory).

Aspen (Atmospheric Sounding Processing ENvironment) is used for analysis and
quality control (QC) of sounding data. It has the following capabilities:

• Automatically apply quality control procedures to the sounding data

• Present data in tabular and graphical forms

• Automatically determine levels and code them in WMO message formats

• Transmit the WMO messages to other systems

• Save the raw and derived data products in various formats

• View multiple soundings in a synoptic map interface

Since Aspen can process data provided in the AVAPS “D” file, Vaisala MW41,
NCAR GLASS, NCAR MCASS, NCAR CLASS, and generic CSV formats, it is able
to analyze both dropsonde and upsonde soundings.

Aspen is designed to operate as automatically as possible, while allowing the user
to have some control over the QC methods. For instance, as soon as the user
selects a sounding file for processing, the data is brought into Aspen and
automatically analyzed. In most cases this first pass will be the only one required.
If the processing needs to be modified, the user can change the QC parameters
and reprocess the data as many times as necessary.

An extensive series of QC algorithms are applied to the data. These algorithms
typically have one or two parameters that may be adjusted by the user if the
default values are not suitable for a particular sounding. The user can save the
modified options, so that when a new sounding is opened, the initial analysis will
use the customized QC parameters.

Aspen is designed so that its operation requires minimal user intervention.
However, there are a few concepts that are very helpful in understanding the
behavior of the program.
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The QC process mainly removes suspect data
points
Aspen maintains two separate data sets: the raw data and the QC data. At the
start of processing, the QC data is an exact copy of the raw data. The algorithms
are then successively applied to the QC data. As the processing proceeds, data
points that fail each test are removed from QC data set. At the end of this process,
a final smoothing is applied to the remaining QC data. It is important to
understand that most of the QC steps simply remove unreliable points from the
raw data set. The dynamic adjustments and the final smoothing are the only steps
where the observed data values are actually modified.

Time is the independent variable
A sounding is simply a time series of observations, and so almost all of the QC
operations are based on the time of each data point. The QC parameters are
specified in relation to time, and the tabular data listings are ordered by time.

The processing follows a fixed sequence
The complete processing routine is applied as soon as a sounding is selected for
analysis, and whenever the user chooses to recompute the analysis. The
sequence is as follows:

1. Apply the QC algorithms, discarding bad points and applying corrections

2. Compute the levels, by analyzing the QC results.

3. Code the WMO message, using the levels as input.

Throughout this manual, notes in italics provide additional
information and suggestions which, while not essential to
operation, will help you use Aspen more effectively.
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Overview of Operations

Run Aspen
To run Aspen, double click on the Aspen icon , or choose Aspen from the start
menu. An initial start screen will appear. If the file selector does not appear
immediately, click the open button (or select Open under the File menu):

You will now see the file selector:

The file selector is used to choose the sounding file to be processed. You can
move to other directories using the up directory button or the directory chooser.
The file filter controls the file types that are displayed in the chooser.
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If you do not see your data files in the directory where they are
supposed to be, it is probably because the file filter is set
incorrectly. Change the file filter to “All files (*)” in order to
display all files in the directory.

Open a file
Select the file containing the sounding that you want to analyze. Click once on the
file and then press “Open”, or double-click the file name.

Aspen will show a warning message if you select a file that is
in a format which it can’t process.

Processing of the sounding begins as soon as the file is opened. The progress of
the analysis is displayed in the status box in the lower left hand corner of the main
screen, but until the processing is complete, the screen will remain blank. When
the sounding analysis has completed, the initial screen will be filled with a tab-
based display, in which each tab represents a different view of the data. The tabs
are arranged from left to right (see figure below) in the general order of the data
processing, i.e. from raw data, through the QC and levels computation, to the
coded message. Read the Tab Displays section for further description.

Verify data
Verify the sounding by examining all of the tab selections. Refer to the Post-
Processing Adjustment section (page 21) for important guidelines on doing this.
After examining the sounding, the user may decide that one or more of the
processing parameters should be adjusted.
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Recompute (if necessary)
The most commonly altered processing parameters can be changed on the Main
tab. When they have been set to the desired values, press the Recompute button
on the Main Tab to reanalyze the sounding using the new parameters.

The processing status will again be displayed in the lower left status box. When
completed, the displays in each tab will be updated with the new results.

Be sure to press the Recompute button after changing the
processing parameters; otherwise, the new parameters will
not be applied to the sounding.

Next sounding
To analyze another sounding, open another data file using the open button. Many
soundings can be open at one time. Use the Window menu to choose which
sounding is displayed.
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Tab Displays
Each tab displays identifying information that describes the
sounding. The details are extracted from various fields within
the raw data file. For graphical displays, this information is
printed as text on the graph. For other tabs, a yellow bar at
the top of the tab contains the identification.

Main Tab

The Main tab is used to view and modify certain characteristics of the sounding,
including launch observations, height integration results, and end of drop time.
See the Post-Processing Adjustment section (page 21) for directions on modifying
information in the Main tab.

Be sure to press “RECOMPUTE” after changing items on the
Main tab.
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Raw Tab

This tab provides the information in the input file in scrollable tabular form. Data
values are listed in time order from the beginning of the sounding, with the launch
observation shown in the first data line with a time of -1s.

Data from the raw tab can be printed or saved to multiple file formats (see Output
File Formats section (page 80)).

Data values that will be removed during Aspen processing are noted with attribute
flags in the Raw tab, as shown above. The flags note which quality control
procedure will remove the data during processing. The Attributes column, on the
right side of the Raw tab, lists the attribute flags that appear in each data line.
Mousing over the attribute abbreviations in this column will show the full names of
the quality control procedures.
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From the Raw tab it is possible to set processing features on selected data points.
Any data cell can be set to either ignore or keep during processing. Ignoring a
data point removes it from the QC data, and can be used to remove bad points
that don’t get removed by Aspen quality control processing. Keeping a data point
will ensure it remains in the QC data, and can be used to override Aspen
processing when it removes points that should be kept. Keep or ignore data
points by selecting the cells you wish to keep/ignore, then right click. In the menu,
you can then select to set the keep or ignore attributes or to clear those attributes.
You will need to press the recompute button after setting or clearing these
attributes.

To select an entire column, click the column header.

It is also possible to set end of drop time from the raw tab by selecting the row
with the desired end of drop time, then right click to access the menu item to set
end of drop time. End of drop time can also be set in the box on the Main tab, and
either process will have the same result.

Use Ctrl+E (Cmd+E on Mac) to jump to the bottom of the raw
tab.

Data lines that come after a user-set end of drop time will appear deselected in
the main tab.

Tab Displays PDF last updated: June 06, 2025

Atmospheric Sounding Processing ENvironment (ASPEN) User Manual Page 10



Cells that have been selected as keep or ignore will show the respective attribute
flag in the raw tab, and will be highlighted in blue. Launch parameters cannot be
assigned keep or ignore attributes, but can instead be modified in the Main tab.
Values in the time column cannot be selected because Aspen indexes data values
by time. Additionally, values in the geopotential altitude, satellites, and wind error
columns cannot be selected because these values are not processed by Aspen
QC.

QC Tab

This tab provides the quality-controlled sounding data in scrollable tabular form.
Data in this tab is the final Aspen product and is what will be written to output
files. Data values are listed in time order, starting with the launch observation with
a time of -1s. Empty cells indicate no data at that time.
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Use Ctrl+E (Cmd+E on Mac) to jump to the bottom of the QC
tab.

Data from the QC tab can be printed or saved to multiple file formats (see Output
File Formats section (page 80)).

XY Graph Tab

This tab provides numerous options for graphical display of the data. Above the
graph are buttons and menus that can select which data to plot and how it is
displayed. The options are as follows:

• Data series selection: The first 5 radio buttons select which data series
to plot on the graph.

◦ T–RH: Selects temperature and relative humidity series.

◦ Speed-Dir: Selects wind speed and direction series.

◦ Sats–Dz: Selects number of satellites and ascent speed series.

◦ Pres-Alt: Selects pressure and altitude series.

◦ Lat-Lon: Selects latitude and longitude series.
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◦ RHs: Selects RH1, RH2, and combined RH series (which appear
in data from RD94 and older dropsondes).

• Data processing selection: The QC, Raw, and Levels checkboxes select
the dataset(s) to be displayed in the graph. Multiple datasets may be
displayed at the same time. When levels are displayed, standard levels
are displayed as triangles and other levels are displayed as circles.

• Display of attribute flags: When raw data is displayed, attribute flags
can be plotted over the data series. Using the drop-down menu flags can
be added, either all flags or flags associated with specific data QC
procedures.

• Y axis selection: These buttons select the parameter displayed along the
vertical axis. Keep in mind that in dropsonde data some lines have data
but no pressure or altitude, so to display all the available data using time
as the vertical axis is recommended. In addition, when the raw data is
displayed using the pressure or altitude vertical axis, the display may be
confusing due to noise in the raw pressure reading.

• Style: This drop-down menu provides options for customizing the view of
the graph: options to add a background grid for either X or Y axis, and
whether to plot data points or to include lines between them.

• Zoom: To magnify (zoom) an area of the plot, left-click and drag to draw a
rectangle around the area of interest. Release the left mouse button to
zoom into the defined area. The UnZm button restores the graph to the
full area display.

The contents of the XY graph can be saved as either PNG or JPG using the Save
button in the Aspen toolbar. PNG provides better compression and much higher
quality graphics presentation for the line drawings of Aspen, and is the preferred
file format. The pixel dimensions of the saved graphic file can be specified in the
configuration options.
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Skew-T Tab

A standard skew-T log-P plot is accessed in the Skew-T tab. Selecting data,
zooming, changing style, and saving of the plot are available in the same manner
as for the XY Graph.

Meteorologists are accustomed to seeing a particular aspect
ratio on skew-T plots and thus a consistent shape of the
various isopleths. To maintain the correct aspect ratio when
zooming, choose a zoom box whose lower left and upper right
corners share a common temperature, i.e. they share a
common diagonal. An example of a correct zooming rectangle
is superimposed on the figure above.
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Levels Tab

The Levels tab displays the computed levels, which have been derived from the
QC data set. The surface and standard levels are highlighted in blue. These are
the levels that are coded in parts A and C of the WMO message. The levels data
can be printed and saved in CSV format from the Aspen toolbar.

The levels listing may be sorted by any of the variables by clicking on the desired
column heading. Clicking a second time in the same heading reverses the order of
the sorting. It is typical to sort either by time or pressure, both of which will give
similar results. In certain cases the Aspen operator may wish to prevent particular
levels from being coded in the WMO message. Clicking on a level in the Levels
Tab will mark a level so that it is not coded. Excluded levels are highlighted in red,
as shown in the above image. Click again on the level to toggle its status back for
normal coding. Clicking on the temperature, RH, speed, direction or altitude fields
will select that individual field and prevent it from being coded in the WMO
message. Clicking on any other field (the columns to the left of these) will disable
the whole level.
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Not all variables are recorded for each level. This is because
each level type is used to report only specific variables in the
coded message. If a variable is not reported for a given level
type, it is not calculated for that level.

WMO Tab

The WMO tab displays the WMO message, which has been coded from the levels
information. It can be printed and saved as a .txt file using the Aspen toolbar.

The WMO message can be emailed from within Aspen by pressing the Email
button on this tab. The email recipient is specified by the TempEmailAddress
configuration parameter. When the Email button is pressed, the default operating
system mail client (e.g. Outlook or Apple Mail) is started, and the user is presented
with an email editing window. If the message is being mailed to an automatic
processing system, such as the NWS email GTS ingest gateway, then the mail
client should be configured to send in plain text format, and to not wrap the text
lines. Group or alias entries can also be made in the client address book (e.g.
“GTS”) to serve as the message recipient address.
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The format for the WMO message is very exacting, and there may be times when
Aspen does not get the coding quite right. The buttons at the top left of the WMO
tab allow the user to modify the WMO message if necessary. Use the mouse to
select the code group to be edited, and press the appropriate editing button.

There are a number of administrative entries in the WMO message that are not
derived from the levels data. These are items such as the abbreviated header, and
information in the 61616 and 62626 groups. This information is managed on the
Comm tab. When a field is changed on the Comm tab, the WMO message is
adjusted accordingly.

If the sounding analysis is recomputed, a new WMO message
will be coded and any edits made previously will be lost.

Comm Tab

The Comm tab is used to enter the administrative information that is coded in the
WMO message, primarily in dropsonde specific groups. It only appears if a
dropsonde file is being analyzed. It also has controls for transmitting the WMO
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message via an attached interface on the USAFR WC130 aircraft. Press the “Send
TEMPDROP message to ARWO” button to transmit the WMO message. A
message box will pop up to indicate that the transmission is in progress.

Data entry fields in the Comm tab are applied to the TEMP
message as soon as they are entered, so there is no need for
the user to press recompute after changing fields. In addition,
most fields are saved and automatically applied to the next
sonde opened (with the exception of sonde-specific
information, like OB number, correction number, environment,
and corrected or last report).

Summary Tab

The Summary tab provides additional diagnostic information about the sounding
input file and the processing Aspen has performed on it, including statistics about
how many points are filtered out during processing and by which procedure. The
information in the Summary tab can be printed or saved in PDF format using the
Aspen toolbar.
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Menu Commands

File Menu
The File menu contains command choices that are generally applicable to all tabs
within Aspen. There are cases when a command cannot be used with a particular
tab. For instance, when the Main tab is selected, the File Save command is not
enabled, since there is no data product associated with this tab. The following
commands are found under the File menu:

Open… Open a sounding file and begin the processing.

Configuration Open the configuration editor (available only when no
soundings are open).

Save… Save data products associated with the tab.

Close Close the sounding.

Close All Close all currently open soundings.

Print Preview Preview the print output.

Print… Print the tab. The output print format will depend on
the tab type.

At the bottom of the File menu is a list of the most recently analyzed files.
Sometimes it is convenient to go here to reopen a sounding that you have recently
examined.

See the Configuration section (page 36) for an explanation of the configuration
management procedures.

Tools Menu
The Tools menu provides access to commands associated with the QC
parameters, when a sounding is open. See the Configuration section (page 36) for
their description.

The Tools menu also provides access to the Synoptic Map view.
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View Menu
The display of toolbar and status bar is controlled in the View menu.

Window Menu
The Window menu contains a listing of all of the soundings currently being
analyzed by Aspen. Clicking on the file name will bring that sounding to the front
of the display. It also provides different options for arranging multiple soundings
within the Aspen window.

Help Menu
The Help menu provides access to information about the version of Aspen, as well
as to the Aspen manual and configuration log.

Toolbar
The Toolbar contains buttons that provide quick access to common Aspen
actions. As with the File menu, the buttons that are enabled depend upon which
tab is currently selected.

Toolbar icons shown here include open, save, print, recompute, synoptic map,
and information.
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Post-Processing Adjustment
Once a sounding has been processed by Aspen, the results must be examined
carefully. Frequently some parameters will need to be adjusted to compensate for
characteristics of the data.

Remember to press the Recompute button after making post-
processing adjustments.

End of data
In a well-behaved sounding, the end of the raw data set will occur at the end of
the sounding. For a dropsonde landing in water, this is the usual case. For a
dropsonde hitting the earth, or with upsondes, the raw data can contain
observations that should not be included in the processed sounding. The user
must then manually specify the end of the drop by setting the end of drop time on
the Main tab. It is critical that the end of drop be correctly set for dropsonde
soundings.

The Raw data table and the XY graph are useful for determining the end time.
Scroll to the bottom of the raw data to view the values of individual data points.
On the XY graph, enable the raw data trace, and use the mouse to zoom in the
area of the sounding end. Data point markers and grids can be enabled with
buttons above the graph.

The Raw tab will continue to display all data from the sonde,
including data after the selected end-of-drop time. The QC tab
will only show data points that are within the end of data time
period.
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Dropsonde heights and the surface
For dropsonde soundings, the height calculations are the trickiest part of the
Aspen analysis. If the drop terminated cleanly at a known altitude, upward
integration of the heights is straightforward. Upward integration is impossible,
however, if the dropsonde termination altitude is unknown. This can occur if the
drop did not make it all of the way to the surface, or if the termination point on
land had an unknown altitude.

In the latter situations, the sounding heights can be computed by downward
integration from the launch altitude. Note that this is suitable only if the launch
altitude is known with accuracy. Usually the launch altitude is provided by the
aircraft data system, and it is critical to determine the accuracy of this altitude. If
altitude is provided by a radar altimeter over the ocean, it is probably acceptable.
If it is provided by a pressure-based altimeter, at some time or distance since the
altimeter setting was applied, the aircraft-provided altitude is probably not
acceptable.

The Main tab has several items that relate to the height calculations.

In the box labeled “Height Overrides” there are check buttons that have the
following effects:

• Hit Surface – The default case. Check this box if the dropsonde hit the
surface. The heights will be integrated up from the surface altitude.
Uncheck this box if the sonde did not hit surface (i.e. stopped
transmitting early) to avoid creating surface levels in WMO outputs.

• Unknown Surface Altitude – Check this box if the surface altitude is
unknown, such as when a dropsonde has terminated on land. The heights
will be integrated down from the launch altitude, and the surface altitude
will be taken from downward integration.

• Set Heights Unknown – Check this box if you feel the heights are not
sufficiently accurate, no matter which way they are calculated. The
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heights will not be calculated or used in latter processing.

At the lower right of the Main tab is a box displaying the results of the upward and
downward height integrations.

This is shown for diagnostic purposes. If downward integration leads to a launch
altitude close to the surface altitude and, likewise, the upward integration is close
to the launch altitude, then there is confidence in the launch altitude. If there are
significant discrepancies, the launch altitude is probably incorrect. Additionally,
differences in the diagnostics can signify a large systematic error in the variables
used in the height integration, i.e. pressure, temperature or humidity.

If the surface altitude can be determined for a launch which terminated on land,
this value can be entered into the surface altitude override box, so that the upward
integration can be computed.

The final item affecting the height calculation is the Launch Altitude entry in the
Launch Parameters box in the upper left of the Main tab. If another source of the
launch altitude is available, it may be entered here in order to override the aircraft
supplied value. The Clear button can be used to remove the override.

It should be pointed out that the heights are mainly relevant to the coding of the
WMO messages, where they are used to report the altitudes of standard pressure
surfaces. Even if the heights are unusable, the WMO message will still contain a
very accurate report of the sounding based on pressure. The upshot is to set
heights to missing when in doubt, rather than report erroneous values.
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Dropsonde end of series adjustments
Some environments show extreme vertical gradients near the surface. Soundings
taken through the hurricane eyewall are a classic examples of this. Sometimes it is
desirable to preserve the high-resolution detail in this part of the sounding,
especially for near surface winds, as these data are critical to hurricane evaluation
and planning.

The standard smoothing in Aspen is usually specified in order to smooth out some
of the variance so that an inappropriate number of levels are not created. But this
also removes the desired detail at the bottom of the sounding. In order to alleviate
this, Aspen creates an additional filtered copy of the pressure and winds series,
and proportionally blends these series back into the main series at the bottom of
the sounding. The blending span is specified by the BlendLength configuration
parameter. BlendLength is also used as the wavelength of the secondary filter.

Launch parameters
The launch parameters are the surface or aircraft flight level observation made at
the time of launch. They become either the bottom or top point in the sounding,
depending on the sounding direction. The QC procedures assume that these
launch observations are accurate, so they will not be changed. If the launch
observations do need to be modified, the Launch Parameters box in the upper left
of the Main tab has entries that allow the user to override or ignore them.
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Select ignore to remove existing launch point values or use the override boxes to
replace them. Use the Clear button to revert to the original values.

Setting the QC parameters
The QC parameters, which control the operation of the various QC algorithms, can
be modified by the user. However, only experienced users who understand the
effects of the parameters should do this. See the Quality Control Procedures
section (page 27) for a complete description.

The QC parameters are organized in named sets, with one of them designated as
the currently active set. The parameters in the active set are the ones used for
succeeding analyses by Aspen. The active set name is displayed on the right side
of the status bar at the bottom of the Aspen application window. It is visible for
every Aspen tab:

The initial installation of Aspen provides a configuration set named “editsonde”,
and designates it as active. These parameters are generally useful for dropsonde
soundings in a tropical environment. Aspen also supplies other config sets for use
with upsondes and different kinds of dropsondes. It is also possible to create a
new config set to address specific data considerations.
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See the Configuration section (page 36) for directions on setting the active set and
maintaining or creating configuration sets.

The user should be in the habit of always checking the status
bar to verify that the correct configuration set is designated as
active.

To change the choice of active configuration set, close all
sounding files within Aspen. The file menu will now have a
“Configuration…” entry that allows access to the configuration
editor.
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Quality Control Procedures
One of the main purposes of Aspen is to apply quality control algorithms to a
sounding. These algorithms attempt to systematically detect data points that are
likely to be incorrect, and remove them from the QC data set.

The processing begins with a copy of the original (raw) observations. In most
cases, all parameters are considered separately. The main exception to this is the
handling of the wind observations. In this case, the wind speed and direction are
separated into u and v components, and the QC tests are individually applied.
However, if one of the two components fails a test, then both components as well
as the speed and direction are removed from the QC data.

There are other QC tests that depend upon the relationship between two
variables; in some algorithms, the processing of a given parameter requires input
from another parameter. For instance, the GPS-measured velocity is used as a
discriminator for the horizontal wind observations. In another case, the dynamic
adjustment procedure requires the time constant of the sensor making the
measurement. This time constant is a function of density and ventilation rate,
which are obtained from the pressure and vertical velocity.

The Algorithms
The following table lists the QC processing steps, in the order that Aspen applies
them. Also listed are the sounding direction and variables to which each step is
applied. Following the table is a more detailed description of each step.

Procedure Downward Upward P T RH* Horizontal
Wind

GPS
Position

Temperature-dependent
dry bias correction†

✓    ✓   

Launch parameter
overrides

✓ ✓ ✓ ✓ ✓ ✓ ✓

Copy raw data set to
QC data set

✓ ✓ ✓ ✓ ✓ ✓ ✓

End of drop override ✓ ✓ ✓ ✓ ✓ ✓ ✓
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Ambient equilibration ✓  ✓ ✓ ✓ ✓  

Post-splash data check ✓  ✓     

Apply fixed offsets ✓ ✓ ✓ ✓ ✓   

RH thresholding ✓ ✓   ✓   

Limit check ✓ ✓ ✓ ✓ ✓ ✓ ✓

Satellite check ✓ ✓    ✓ ✓

Wind error check ✓ ✓    ✓  

Buddy check ✓ ✓ ✓ ✓ ✓ ✓ ✓

Outlier check ✓ ✓ ✓ ✓ ✓ ✓  

Filter check ✓ ✓ ✓ ✓ ✓ ✓ ✓

Pressure smoothing ✓ ✓ ✓     

Monotonic pressure
check

✓ ✓ ✓     

Compute vertical
velocity (1)

✓ ✓      

Temperature dynamic
adjustment

✓ ✓  ✓    

RH limiting (1) ✓ ✓   ✓   

Final smoothing ✓ ✓  ✓ ✓ ✓  

RH limiting (2) ✓ ✓   ✓   

RH without temperature
removal

✓ ✓   ✓   

Pressure adjustment ✓  ✓     

Compute vertical
velocity (2)

✓ ✓      
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Vertical velocity check ✓     ✓  

Compute vertical winds ✓       

Create surface
observation

✓  ✓ ✓ ✓   

Winds dynamic
adjustment

✓ ✓    ✓  

Fast fall check ✓       

Compute altitude ✓ ✓      

Compute position ✓ ✓      

* Aspen assumes humidity is given as RH w.r.t. water, which is the meteorological
standard, but does not check this. Refer to documentation for the sensor you are
using for more information.

† Only applied to specific range of RS94 dropsondes that need the correction.

More details about each processing step follows. Some algorithms are linked to
their pages in the QC Algorithms section of AspenDocs. If the step can be
adjusted via a configuration parameter, the name of the configuration parameter in
the config set and how to access the parameter value in Aspen are listed. See the
Configuration section for details on managing Aspen configurations.

Temperature-dependent dry bias correction

A correction is applied to the RH series if a) the sonde is in the specific range of
RD94 sondes that need the correction and b) if the correction is not already
present in the input data. If the correction is present in the input data, any RH
values of 0.1 (signifying very low but nonzero RH) are flagged and removed.

Launch parameter overrides

Settable: Main tab

The user-specified launch parameter overrides, if any, are substituted for the ones
given in the data file.

Copy raw data set to QC data set

Parameters: DiscardBadCrcData
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Settable: Options > Processing > Discard frames with CRC errors

The QC data set is initialized with a copy of the original observation. If the option
is chosen to discard frames with CRC errors or sonde ID errors, these frames are
not copied to the QC data set.

End of drop override

Settable: Main tab

If the user has specified an end of drop time, all data beyond this time is ignored.

Ambient equilibration

Parameters: WindEquilTime

Settable: Options > QC Parameters > Dropsonde equilibration time override

See Ambient Point.

Post-splash data check

See Post-splash check.

Apply fixed offsets

Parameters: PresOffset , TdryOffset , RHOffset

Settable: Options > QC Parameters > Offset to add

See Offset Adjustment.

RH thresholding

Parameters: RHThreshold

Settable: Options > QC Parameters > Thresholding

Optionally thresholds RH values outside the 0-100% range that still may contain
valid data. Thresholding sets RH values between -5% and 0% to 0% and between
100% and 110% to 100%. This thresholds values before quality control takes
place, unlike the separate RH limiting that gets applied after processing and is not
user-configurable.

Limit check

See Limit Check.
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Satellite check

Parameters: WindDisableSatsCheck , WindSats

Settable: Options > QC Parameters > Disable sats check or set minimum number
of satellites

See Satellite Check.

Wind error check

Parameters: WindDisableErrorCheck , WindErrorHigh , WindErrorLow

Settable: Options > QC Parameters > Disable wind error check or set limits in
upper and lower atmosphere

See Wind Error Check.

Buddy check

Parameters: PresBuddySlope , TdryBuddySlope , RHBuddySlope ,
WindBuddySlope , GPSPosBuddySlope , GPSAltBuddySlope

Settable: Options > QC Parameters > Buddy check slope

See Buddy Check.

Outlier check

Parameters: PresDisableOutlierCheck , PresOutlier ,
TdryDisableOutlierCheck , TdryOutlier , RHDisableOutlierCheck ,
RHOutlier , WindDisableOutlierCheck , WindOutlier

Settable: Options > QC Parameters > Outlier check or disable outlier check

See Outlier Check.

Filter check

Parameters: PresQCWL , PresQCDev , TdryQCWL , TdryQCDev , RHQCWL ,
RHQCDev , WindQCWL , WindQCDev , WindDisableQCFilter , GPSPosQCWL ,
GPSPosQCDev , GPSAltQCWL , GPSAltQCDev

Settable: Options > QC Parameters > QC filter wavelength, QC filter deviation
limit, disable QC filter

See Filter Check.
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Pressure smoothing

Parameters: PresSmoothWL

Settable: Options > QC Parameters > Final smoothing wavelength

The smoothing is applied to the pressure data. The pressure needs to be
smoothed before the pressure monotonic check. If the final smoothing wavelength
is set to 0, this is not applied. A small amount of final smoothing should almost
always be applied to pressure, so that reverse trends in pressure caused by noise
will not cause a data point to be discarded. See Smoothing for more details.

Monotonic pressure check

Parameters: PresMonoCheck

Settable: Options > QC Parameters > Pressure monotonic check

The pressure trace must change monotonically in order for pressure-based
searching to be performed. The pressure time series is scanned; when a point is
found which follows an incorrect trend (i.e. decreasing for a dropsonde, increasing
otherwise), it is removed from the series.

Compute vertical velocity

See Vertical Velocity.

Temperature dynamic adjustment

Parameters: TdryDynCor , TdryDynCorWL

Settable: Options > QC Parameters > Dynamic correction and dynamic correction
wavelength

See Dynamic Adjustment.

RH limiting

Incoming RH values can be outside the 0-100% range, but Aspen will not output
QC values outside of the range. After other QC processing has been done, make
sure RH values are still within what’s physically possible. RH values less than
0.1% are set to 0.1% and RH values greater than 100% are set to 100%. This is
performed a second time after final smoothing, since that can adjust RH values to
outside of the allowable range.
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Final Smoothing

Parameters: TdrySmoothWL , RHSmoothWL , WindSmoothWL , BlendLength

Settable: Options > QC Parameters > Final smoothing wavelength

The series are smoothed using the final smoothing wavelength. If the final
smoothing wavelength is set to 0, this is not applied. See Smoothing for more
details.

RHs without Temperatures

Humidity data as percent relative humidity is not valid unless there is a
temperature observation at the same point. At this step in the processing, Aspen
checks that each RH value has a temperature value at the corresponding time,
and removes those that don’t.

Pressure Adjustment

Settable: Main tab

See Scalar Adjustment.

Vertical velocity check

Parameters: WindVVDelta , WindVVPresWL , BlendLength , ChuteArea ,
DragCoef , DropSondeMass

Settable: Options > QC Parameters > Vertical velocity difference limit and
pressure smoothing wavelength, Options > Processing > Dropsonde parameters

See Vertical Velocity Check.

Compute vertical winds

Parameters: WindDisableW , ChuteArea , DragCoef , DropSondeMass

Settable: Options > QC Paremeters > Disable Vertical Winds Calculation, Options
> Processing > Dropsonde Parameters

See Vertical Wind.

Create surface observation

See Create Surface Observation.
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Winds dynamic adjustment

Parameters: WindDynCor , WindDynCorWL

Settable: Options > QC Parameters > Dynamic correction and dynamic correction
wavelength

See Dynamic Wind Adjustment.

Fast fall check

The hydrostatically computed vertical velocity is compared with the theoretical
value. If more than 50% of the values are greater than 1.35 times larger than the
theoretical value, the observation is flagged as a “fast fall” sounding. See Fast Fall
Check.

Compute altitude

See Altitude and the Post-Processing Adjustment section (page 21) for a
description of height computations.

Compute Position

Parameters: ReportObservedPos , PosInterpSpan

Settable: Options > Processing > Report observed position instead of integrated
winds position, position interpolation interval

See Position.

Guidelines for Adjusting QC Parameters
The supplied default values for the Aspen QC parameters in general produce
excellent results. However, there may be times when a group of soundings have
peculiar error characteristics, and the Q/C parameters need to be modified in
order to produce better discrimination against outliers. Some tips for adjusting the
configuration parameters are given here. The user should carefully read and
understand the descriptions of the QC algorithms given in the preceding section;
this will provide the best guidance on modifying the QC parameters to match the
error characteristics of the sounding data.

• Toggle the display of raw data off and on in order to see which data
points are being rejected by the algorithms. Toggle the “mark points”
option, and use the zoom and pan capabilities freely to investigate the
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effectiveness of the procedures.

• If the sounding system does not report the number of GPS satellites used
in the winds calculation, set the GPS satellite threshold to 0, so that
winds are not discarded due to a lack of satellites.

• The most frequently adjusted parameters are the the QC filter wavelength
and the QC filter deviation, which are used in the filter check and are
applied together. In this algorithm, a smoothed curve is calculated from
the data series. If the filter wavelength is small, the curve will closely
follow the data; if large the curve will be a very smooth representation of
the data. The deviation is the amount that a data point is allowed to
deviate from the smoothed curve. If the difference between the curve and
the raw data point is larger than the deviation, the data point is discarded.
The interplay between the amount of smoothing and the allowed
deviation allow for wide latitude in tuning the filter check algorithm.

• The dynamic adjustments for temperature and wind speed can
significantly increase the variance of the data series. If the QC results
appear noisier than the raw data, it will be due to the dynamic
adjustments. Use of the dynamic adjustments is the prerogative of the
user, and can be deactivated in the configuration. Note that the tendency
of the series, used in the adjustment, is calculated from a smoothed
version of the data. The dynamic correction smoothing wavelength is
used for the smoothing value during the dynamic adjustment procedure.
If a very small smoothing wavelength is specified, the variance increase in
the QC data can become significant.
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Configuration Parameters
Aspen is very flexible and can produce a large variety of output products. It will
analyze data from a number of different sounding systems. In order to tailor it for
differing applications, Aspen provides a configuration system. This same system is
used to configure Aspen, BatchAspen and Aspen-QC, and the configuration
information is shared between each of these programs.

Configuration Items: At the heart of the configuration system is the configuration
item, which matches a keyword with a current value, and a default value. The
keyword identifies a particular characteristic to be used during the next Aspen
analysis; e.g. the smoothing wavelength to be applied the pressure field, or the
mass of the dropsonde.

Configuration sets: A collection of all configuration items is collected in a
configuration set. Configuration sets are assigned names, and a named set is
chosen as the currently active one, to be used the next time that Aspen is run. In
this way, users can create configuration sets that are tailored to a particular
instrument, environment, or field program, and switch between them as needed.

The Active Set: At any time, one of the named configuration sets is designated as
the active set. This means that any further processing with Aspen or BatchAspen
will use the configuration items from the active set.

It is critical that the user verify that the correct set has been
designated as active when processing soundings.

A user interface is provided within Aspen and BatchAspen for manipulating the
Aspen configuration. This is divided into two activities. The first is the
management of the configuration sets: creating, deleting and activating a set. The
second is modification of the configuration items within a selected set.

Note that within Aspen, the management of the configuration
sets can only be initiated from the File menu, when no
soundings are currently open. Configuration items for any
named set may be modified at this time also. However,
configuration items for the currently active set may also be
modified when soundings are open within Aspen.
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aspen.xml: The configuration information is stored in XML format, in a file named
aspen.xml . A “Document Type Definition file”, aspen.dtd , accompanies
aspen.xml , and must be located in the same directory.

The location of these files depends upon the operating system as well as the
ASPENCONFIG environment variable. When Aspen first runs, it checks to see if
ASPENCONFIG is set. If it is, Aspen then checks for the existence of the

configuration files in that directory. If the files are not found, Aspen offers to copy
default configuration files to that directory.

If ASPENCONFIG is not set, Aspen will assume directories for the configuration
files, according to the following:

• Linux and OSX: username/.config/aspen

• Windows: username\Application Data\Aspen

This scheme allows individual users to maintain their own versions of
configuration files. It also allows users to retain their custom config sets when
upgrading to a new version of Aspen.

Configuration Set Management
Management of the configuration sets is available through the File > Configure…
menu within Aspen and BatchAspen. Choosing this item will cause a configuration
set management dialog to open, from which configuration sets may be activated,
deleted, created and edited:
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The selection drop down box at the top of the dialog is used to select the named
configuration set that all other operations will reference. The selected set can be
activated, deleted, or edited using other buttons in the dialog. To create a new
configuration set, select an existing set to be used a source set, enter a name in
the box, and press the Create button. When all configuration editing actions are
finished, use the OK button to save them, or the Cancel button to discard the
changes.

The individual configuration items for the selected configuration set can be edited
by pressing the Edit button. This will bring up a dialog from which the quality
control parameters and other options can be modified. See the “Changing the QC
Parameters” section (below) for details on modifying the configuration items from
this dialog. Pressing the Restore Defaults button will restore the entire set of
configuration items for the selected set, restoring them to their default values.

The Sample Configuration Set: There is a special configuration set, named
sample, provided with Aspen. This set cannot be activated, deleted or edited. It is
available as a default set that can be used as the source when creating a new
configuration set.
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Remember that within Aspen, the configuration editor is only
available (from the File > Configure… menu) when no
soundings are open. When soundings are open in Aspen, the
options for the currently active configuration set can be edited
from the Tools > Options menu.

Changing configuration set values
In order to configure Aspen to match your particular requirements, the
configuration items (i.e. parameters) within a configuration set must be properly
specified. This can be initiated from either the configuration management menu
(File > Configure… > Edit Options) when no files are open, or from the options
menu (Tools > Options…) when a sounding is open. A tabbed property sheet will
open, with six different views.

QC Parameters

The quality control parameters are used to adjust the various quality control
algorithms, and are described in the Quality Control Procedures section (page 27).
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Processing

QC processing mode: This controls which, if any, quality control Aspen will
perform on each sounding that is loaded.

• None: No quality control is done, and no data products are generated.
Aspen can be used to view the raw data in XY Graph or Skew-T formats.

• Normal: The default value. Aspen performs all quality control algorithms.

• Pass through: Quality control is not performed, but data products (levels,
WMO TEMP and BUFR files) can be created. This mode can be used to
treat Aspen as a format conversion tool for sounding data that has
already been quality controlled.

• TD dry bias only: Aspen performs no quality control except for applying
the temperature-dependent dry bias correction.

Levels and WMO Message: Controls whether Aspen generates levels or WMO
data products for each sounding that is loaded. These two features should always
be enabled if WMO messages are the ultimate data product (e.g. weather
reconnaissance). For other uses, these features may be turned off.
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Levels Threshold: These five parameters set the thresholds used in the
determination of the GDL levels for the designated measurement. They should be
modified with caution, since this would result in a deviation from the specifications
of the FMH-3.

Dropsonde mass, parachute area and coefficient of drag: The dropsonde
mass, parachute area and coefficient of drag are required in order to estimate the
initial fall speed of the dropsonde, after launch from the aircraft. The values differ
only from the defaults in special cases where a custom parachute or modified
sonde are deployed.

Blend length: This specifies the blend interval and filter wavelength for the
blending of higher frequency smoothing of pressure and winds at the bottom of a
dropsonde sounding. This applies only to dropsonde soundings.

Cabin temperature: When a sonde is launched from within an aircraft or gondola,
the temperature sensor will be close to the temperature within the cabin or
gondola. The difference between the cabin and the external ambient temperature
is used to calculate the number of temperature sensor time constants required for
the sensor to reach ambient conditions. This parameter provides the value used
for the cabin temperature.

RH Channel: The AVAPS/Dropsonde RSS80 and RSS94 systems use a sonde
that carries dual relative humidity sensors. The firmware in the sonde chooses the
humidity value from one of them, and the selected channel is reported in the main
RH field of the “D” file. The original values for both sensors are reported in
additional columns in the file. The user can elect to use the sonde chosen value
(AVAPS selected), or either of the original sensor values (RH1 or RH2).

Dropsonde hit surface: This box is checked if the dropsonde was believed to
have hit the surface (the default case). This causes the sounding altitudes to be
integrated from the surface altitude upwards; otherwise they will be integrated
from the flight level altitude (if available) downward. If checked it also allows the
computation of an extrapolated surface data point. Uncheck this box if it is
believed the dropsonde did not hit surface (i.e. stopped transmitting early) to use
the downward integration for heights and to avoid coding surface levels in WMO
messages. This parameter can also be changed from the Main tab.

Surface altitude unknown: Check this box if the dropsonde was believed to have
hit the surface, but the surface altitude is unknown, as in a dropsonde landing on
the earth. It causes the height integration to be performed from flight level down,
but will still calculate surface levels in WMO messages. This parameter can also
be changed from the Main tab.

Discard frames with CRC errors: If this box is checked, data frames that are
marked as having a CRC error are discarded. This only applies to AVAPS
dropsonde soundings.
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Discard frames with wrong sonde ID: If this box is checked, data frames that
are marked as having the wrong sonde ID (i.e., frames received from the wrong
sonde) are discarded. This only applies to AVAPS dropsonde soundings in ACS
netCDF format.

Use theoretical fall rate for sensor ventilation rate: The sonde fall rate is used
in some time constant calculations. Using the observed fall rate of the sonde may
include noise or atmospheric abnormalities (e.g. updrafts) that can interfere with
these calculations. If this box is checked Aspen will use the calculated theoretical
fall rate for these calculations.

Tropopause Levels Detection: The lapse rate smoothing wavelength is the
wavelength of the smoother that will be applied to the temperature data before the
automatic determination of tropopause levels is made. A tropopause is identified
by the derivative of the temperature lapse rate, and so a high variance in
temperature can lead to the creation of unrealistic tropopause levels.

Set heights missing: Check this box to cause the height computations to be
skipped, in cases where the operator does not trust the data to provide for
accurate height integration.

Descending GAUS: Check this box if using descending data collected by a
radiosonde using the GAUS system.

Report observed position instead of integrated winds position: By default the
winds are integrated from the launch point in order to determine position. Select
this option in order to use the GPS observed position (GPS sondes only).

Open maximized on startup: If this box is checked, Aspen will open a window as
large as the available display.

Open file browser on startup: If this box is checked, a file browser dialog will
open as soon as Aspen is started. Otherwise, the File menu can be accessed in
order to select a file to process.

Generate Q/C diagnostics file: Select this to cause a file with Q/C diagnostic
information to be created. The file name will begin with ‘AspenDebug’ and have a
.txt extension. It will be created either in the directory where the Aspen program is
installed, or the directory where the first data file is located. Be sure to disable this
option when finished, otherwise diagnostic files will be created every time Aspen
is run. After selecting this option, Aspen must be restarted to begin generating
diagnostic files.

Position interpolation interval: Set the maximum time interval over which the
winds can be interpolated for the position integration calculation. If the gap in
winds is greater than this interval, the winds will not be interpolated and the
position integration will stop.
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Geopotential alt interpolation interval: Set the maximum time interval over
which the geopotential altitude can be interpolated. If the gap in pressure data is
greater than this interval, the geopotential altitude will stop at the gap.

QC Comment: Text entered here will be appended to the file metadata in EOL
format output.

Fixed Data Source and Destination Directory: This will set the save locations for
all Aspen outputs to the specified directory, as well as automatically opening the
file chooser to that directory.

Kermit Path: Path to Kermit file transfer program. Only used by AFRES 53rd
aircraft.

Metadata add or override: Some sounding systems and file formats include
metadata that can give additional information about the context of the sounding. If
information is not present or not correct in an input file, it can be overridden using
these boxes:

• Agency:: Organization performing the sounding (e.g. NOAA, AF, NCAR)

• DOI: The Digital Object Identifier (DOI) that identifies the project or
dataset this sounding is part of

• Platform type: Type of aircraft or sounding system used (e.g. G-IV, NCAR
GAUS)

• Platform ID: Identifier of platform (e.g. tail number of aircraft)

• Project: Name of project or mission sounding is a part of

• Flight/IOP: Name of subset of project or mission
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WMO

These parameters contain the information needed to send WMO messages to
operational centers for real-time model ingest.

WMO Message Type: Choose the type of TEMP message to be generated for an
upsonde sounding.

Block Station Number and Call Sign: These are identifiers that are required
either for the TEMP, TEMPSHIP, or TEMPMOBIL messages.

Upsonde Abbreviated Header: The WMO abbreviated header for upsonde WMO
messages. (Note that dropsonde abbreviated headers are specified on the Comm
tab).

Upsonde ICAO Code: ICAO code for upsonde abbreviated headers. (Note that
dropsonde ICAO codes are specified on the Comm tab).

Email address for TEMP: Address to receive an emailed WMO message.

Append NNNN Terminator: If checked, append NNNN to the WMO message
when it is saved or emailed. Some communications systems, such as the GTS,
require this terminator.
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Disable Abbreviated Header: If checked, the abbreviated header will not be
generated for the TEMP message. This is useful in the common situation where
another system generates the abbreviated header.

BUFR originating center numeric: WMO identifier of source of BUFR data.

Prepend BUFR abbreviated header: Add abbreviated header to the beginning of
the BUFR message.

BUFR abbreviated header: Controls the contents of the header prepended to the
BUFR message.

BUFR originating center ICAO: WMO identifier of source of BUFR data.

Auto Save

Aspen can be configured to automatically save output products for each file
opened. This tab lets users enable auto save, select the directory to save output
to, and select which output products should be automatically saved.
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Synoptic Map

The paths to the geographic map background database and the soundings
database are specified here, as well as the optional title of the synoptic map. See
the Synoptic Map section (page 61) for more details.
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Visual

XY Graph settings: The minimum and maximum values for each variable that can
be displayed in the XY graph can be set here, or can be set to scale automatically
based on the minimum and maximum values of the data series that is currently
being plotted.

Skew-T Graph settings: The size of the image produced by saving the skew-T
graph, as well as limits for temperature and pressure to display on the graph, can
be set here.

Text settings: The font and size of the text in Aspen displays can be set here.

Saving Changes and Restoring Defaults
When the user closes a sounding in which the QC parameters have been
changed, a dialog box asks if these parameters should be saved as the
processing defaults. If the parameters are saved, all soundings opened after this
time will be processed using these options. The Tools menu provides a command,
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Tools > Restore Defaults, which can be used to restore the options to initial
system defaults. Thus the customized parameters will revert to the initial
installation defaults.

The user may also revert the QC parameters to the initial installation defaults
before opening any soundings. This is done via the File > Configuration… >
Restore Defaults button (available only when no soundings have been opened).

When in doubt about the proper values of the QC parameters,
restore the defaults.

Corrupted Configurations
As described above, the configuration information is stored in the aspen.xml file.
If the configuration file becomes corrupted, Aspen will not be able to run, and the
file will need to be repaired or restored. The file AspenOriginal.xml is provided
as a copy of the originally distributed configuration file, and is located in the Aspen
installation directory. In the worst case, this file can simply be copied over
aspen.xml (note that the file name case is significant). This will restore Aspen to

the default configuration parameters, but all changes or additions that have been
made to the configuration will be lost.

If the aspen.xml file is only slightly corrupted, it may be possible to correct the
error with a text editor. A simple way to locate a syntax error is to open
aspen.xml in an internet browser, which provides structured viewing of XML

files. The browser will indicate lines that do not parse correctly, and then a
standard text editor may be used to fix minor problems.
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Configuration Parameters
The Aspen configuration is stored in XML format. There are two files: aspen.xml
and aspen.dtd . aspen.xml contains the actual configuration values, while
aspen.dtd defines the syntax of the aspen.xml file.

XML elements are delineated by start and end tags, and are nested to create a
hierarchical data structure. aspen.xml observes the following structure:

<aspenConfig>
<active>dropsonde</active>
<set name="sample">

<option name="ReportObservedPos" type="bool">
<current>false</current>
<default>false</default>

</option>
.
.
.
<option immediate="true" name="CallSign" type="string">

<current>CALL</current>
<default>CALL</default>

</option>
<option immediate="true" name="IcaoIndex" type="numeric">

<current>1.000000</current>
<default>1</default>

</option>
</set>
<set name="dropsonde">
.
.
.
</set>
</aspenConfig>

Thus, the Aspen configuration contains one entry ( <active> ), designating which
named configuration set is active, followed by one or more named configuration
sets ( <set> ). Each configuration set contains a list of configuration options
( <option> ), with the current and default values for each option. Each option has
a designated type:
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• bool – boolean, with a value of either true or false.

• numeric – A floating point numeric value.

• string – A text string.

An option may also be marked with immediate=true to effect an immediate save
of the option when it is changed. It is useful for some options to be saved
immediately after they are changed, before closing the sounding in Aspen, so that
when the next sounding is analyzed, it will immediately use the new version of the
option. For instance, if the dropsonde operator on the Hurricane Hunter aircraft
opens a sounding, and then changes the ICAO value for the TEMP message, it is
likely that all soundings opened during the same run of Aspen should use this
value for the ICAO string. An immediate save allows the configuration to be
updated, without having to close that sounding.

The case of the configuration item name is critical. It must be
matched exactly as shown.

QC algorithm parameters
WindSmoothWL int

WindQCWL int

WindDynCor bool

WindDynCorWL int

WindBuddySlope double

WindQCDev double

WindDisableQCFilter bool

WindOutlier double

WindDisableOutlierCheck bool

WindSats int

WindDisableSatsCheck bool

WindErrorHigh double
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WindErrorLow double

WindDisableErrorCheck bool

WindVVdelta double

WindVVPresWL int

BlendLength int

WindEquilTime double

WindDisableW bool

PresSmoothWL int

PresQCWL int

PresBuddySlope double

PresQCDev double

PresOutlier double

PresDisableOutlierCheck bool

PresOffset double

PresMonoCheck bool

TdryQCWL int

TdryDynCor bool

TdryDynCorWL int

TdryQCDev double

TdryOutlier double

TdryDisableOutlierCheck bool

TdryOffset double

TdryBuddySlope double
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TdrySmoothWL int

RHSmoothWL int

RHQCWL int

RHBuddySlope double

RHQCDev double

RHOutlier double

RHDisableOutlierCheck bool

RHOffset double

RHThreshold bool

GPSPosBuddySlope double

GPSPosQCWL int

GPSPosQCDev double

GPSAltBuddySlope double

GPSAltQCWL int

GPSAltQCDev double

Processing parameters
DiscardBadCrcData bool

DiscardBadSondeId bool

ReportObservedPos bool

DoQC int

descendingGAUS bool

ChuteArea double
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UseTheoryVentRate bool

DragCoef double

DropSondeMass double

CabinTemp double

PosInterpSpan double

AltInterpSpan double

RHchoice int

QCDisclaimer string

Sonde metadata parameters
Agency string

AircraftType string

AircraftId string

Project string

Flight string

DatasetDOI string

Levels generation parameters
DoLevels bool

TdryLevelDelta double

RHLevelDelta double

WspdLevelDelta double

Wspd850LevelDelta double
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WdirLevelDelta double

TropSmoothWL double

WMO message generation parameters
DoWMO bool

CallSign string

BSN string

TempMsgType int

TempAppendNNNN bool

ExcludeAbrHdr bool

UpsondeAbrHdr string

UpsondeICAO string

TempEmailAddress string

BufrOrigCenter int

BufrAddAbrHdr bool

BufrAbrHdr string

BufrOrigCenterICAO string

ACagency string

MissionStorm string

MissionId string

IcaoIndex int

AbrHdrOvr string

AtcfId string
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OptIcao string

ResampleBufr bool

WMO message sending parameters
DisableKermit bool

KermitPath string

BaudRateIndex int

CommPortIndex int

User setup parameters
DataDir string

WmoSaveDir string

QCSaveDir string

RawSaveDir string

XYPlotSaveDir string

SkewTPlotSaveDir string

FixedSrcEnabled bool

FixedSrcDir string

QcDiagFile bool

GeoDBPath string

SoundingDBPath string

SynopticMapTitle string

OpenFileSeleFilter string
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AutoFile bool

OpenMaximized bool

Visual parameters
PlotPixelsX int

PlotPixelsY int

NumberSkewTWinds int

SkewTtmin double

SkewTtmax double

SkewTpmin double

SkewTpmax double

TextSizePt int

FontFamily string

xyGraphPresAuto bool

xyGraphPresMin double

xyGraphPresMax double

xyGraphAltAuto bool

xyGraphAltMin double

xyGraphAltMax double

xyGraphTdryAuto bool

xyGraphTdryMin double

xyGraphTdryMax double

xyGraphRHAuto bool
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xyGraphRHMin double

xyGraphRHMax double

xyGraphWspdAuto bool

xyGraphWspdMin double

xyGraphWspdMax double

xyGraphWdirAuto bool

xyGraphWdirMin double

xyGraphWdirMax double

xyGraphDzDtAuto bool

xyGraphDzDtMin double

xyGraphDzDtMax double

xyGraphLatAuto bool

xyGraphLatMin double

xyGraphLatMax double

xyGraphLonAuto bool

xyGraphLonMin double

xyGraphLonMax double

Autosave parameters
QCAutoSaveEnable bool

QCAutoSaveDir string

QCAutoSaveFmtEol bool

QCAutoSaveFmtFrd bool
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QCAutoSaveFmtCls bool

QCAutoSaveFmtNc bool

QCAutoSaveFmtCsv bool

QCAutoSaveFmtBufr bool

SkewtAutoSaveFmtPng bool

SkewtAutoSaveFmtJpg bool

SkewtAutoSaveFmtSvg bool

WmoAutoSaveFmtTxt bool

WmoAutoSaveFmtCsv bool

SumAutoSaveFmtTxt bool

BatchAspen parameters
BatchSaveDir string

BatchSaveRawCLS bool

BatchSaveQCCLS bool

BatchSaveRawEOL bool

BatchSaveQCEOL bool

BatchSaveQCFRD bool

BatchSaveQCBUFR bool

BatchSaveRawCDF bool

BatchSaveQCCDF bool

BatchSaveRawCSV bool

BatchSaveQCCSV bool
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BatchSaveWMO bool

BatchSaveSkewTSvg bool

BatchSaveSkewTPng bool

BatchSaveLevels bool

Per-sounding parameters
Some processing adjustments make sense to apply to a single sonde, but not to
set as the default for processing all sondes. Examples of this include overriding
end-of-drop time or indicating that the sonde did not hit surface. These items are
by default not saved in the aspen.xml configuration file, but are part of the
configuration set while Aspen is running. These parameters can be changed in
Aspen via the Main tab or the Tools menu, and can be modified as command line
arguments to Aspen-QC .

SetHtsMissing bool

DropsondeHitSfc bool

SfcAltUnknown bool

SfcAltOverride double

SfcPresOverride double

LastDataTimeOverride double

PresEquilTimeOverride double

RHEquilTimeOverride double

TdryEquilTimeOverride double

IgnoreLaunchAlt bool

IgnoreLaunchLat bool

IgnoreLaunchLon bool

IgnoreLaunchPres bool
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IgnoreLaunchRH bool

IgnoreLaunchTdry bool

IgnoreLaunchWdir bool

IgnoreLaunchWspd bool

LaunchAltOverride double

LaunchPresOverride double

LaunchTdryOverride double

LaunchRHOverride double

LaunchWdirOverride double

LaunchWspdOverride double

LaunchLatOverride double

LaunchLonOverride double

ObsNum int
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Synoptic Map
The Synoptic Map provides a plan view of station models for soundings, at
selected levels. These are overlaid on a geographic basemap.

If Aspen has been reinstalled you may be prompted to
configure the geographic database location. See
Configuration. (page 61)

Databases and Configuration

Sounding Database

Every time Aspen processes a sounding, Q/C data are written to the sounding
database. The Synoptic Map uses this as a data source for plotting the map, and
the individual soundings are identified in the database by the source data file
name. The database is created the first time that you run Aspen.

This is a simple SQlite3 database, which is a single file. You can maintain separate
databases as needed, simply by selecting a different file name and/or location.
You can even use the SQlite3 database for your own applications, if desired.

Soundings may be removed from the database using the Synoptic Map sounding
browser. If a sounding is processed multiple times in Aspen, the most recent data
replaces existing values in the database.

Geographical Database

The shape data for the geographical base map is also stored in an SQlite3
database. This geographical database is distributed with Aspen. Because it is
difficult for a program to easily determine its install location on multiple operating
systems, you must configure Aspen to locate this database.

Configuration

You will be prompted to enter the database locations when the Synoptic Map is
opened for the first time. The default location can be used for the sounding
database.
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The explicit location of the geographical database must be provided. This will be a
.sqlite file in the Geodata directory below where Aspen is installed, e.g.:

username/AspenV3.4.1/Geodata/ne1to50m.sqlite

The Aspen installation location may vary, but it is typically in
the user’s home directory.

The database file locations can also be changed from the Synoptic Map tab of the
standard Aspen configuration screen:

Usage
Open the Synoptic Map from the Tools menu, or by clicking the World button:
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A new window will open, displaying a world map. A control panel and database
browser are shown on the right side. Select soundings in the database browser to
display them on the map.

Map Navigation

• Left-click and drag to zoom into a region.

• Right-click to revert one zoom step.

• Use the radio-buttons at the top of the control panel to select the map
mouse behavior. You can also just double click on the map to cycle
through these options.

• Use the Station Level drop-down to select which sounding level to
display. Standard pressure levels and a few diagnosed levels are
available.
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Station Model

Synoptic Map PDF last updated: June 06, 2025

Atmospheric Sounding Processing ENvironment (ASPEN) User Manual Page 64



Each observation for the selected level is depicted by a standard meteorological
station model. If there is no data for the sounding at that particular level, a single
small circle is displayed.

The station model elements are selected on the control panel. They are:

• Temperature (degrees C).

• Dew point temperature (degrees C).

• Pressure if at the surface (10*mb); altitude if above the surface (msl).

• Time of the sounding (UTC).

• Wind direction (the barb points into the wind).

• Wind speed, determined by summing the flags:

◦ half line segment: 5 kts.

◦ full line segment: 10 kts.

◦ triangle: 50 kts.

When you hover over the center of the station model, the
circle will turn red and identifying information will pop up. Click
right to select reprocessing of the sounding, or to remove it
from the map.

Saving Images

Map images may be saved when the Synoptic Map window is open. Select the
desired save option from the main Aspen File menu:
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Saving the current synoptic level will generate one image. Saving all synoptic
levels will generate a set of images, one for each station level available.

Control Panel

The control panel has display options at the top, and a sounding browser on the
bottom. Note that different sounding information may be displayed by scrolling the
browser window left/right. Mouse behavior, station model features, and displayed
levels are selected from the options.

The station model is generally too busy when all parameters
are selected for display. De-clutter the display unchecking the
ones that you don’t really need.

• Displaying a sounding: Click on the sounding name to (de)select it.

• Deleting a sounding: Use the check boxes and the Delete button to
permanently remove a sounding from the database. It can be added back
to the database by reprocessing the sounding file with Aspen.

• Changing the database: Use the Change DB button.

Synoptic Map PDF last updated: June 06, 2025

Atmospheric Sounding Processing ENvironment (ASPEN) User Manual Page 66



Synoptic Map PDF last updated: June 06, 2025

Atmospheric Sounding Processing ENvironment (ASPEN) User Manual Page 67



BatchAspen
BatchAspen is a separate application that is used to apply the Aspen Q/C
procedures to a collection of multiple sounding files. The user selects the data
products to be created. The program then iterates over the list of files, placing the
results in a specified destination directory.

BatchAspen shares an exact copy of the QC processing
algorithms that are used by Aspen, so that identical results for
both programs can be guaranteed. The exception to this is
when modifications are made by the user during standard
Aspen processing.

Starting BatchAspen and Selecting Files
Start the application by clicking on the BatchAspen icon or selecting BatchAspen
from the start menu. A single screen will be presented.
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To add files for processing, drag and drop the files into the processing list on the
right side of the window, or use the Open button in the toolbar or File > Open to
select one or more files for processing. Files may be removed from the processing
list by selecting them in the processing list, and pressing the “Remove” button, or
press “Remove All” in order to empty the list completely.

Files from multiple directories can be collected in a single
processing list. However, all output files will be created in a
single directory.

To select the output directory, press the “Change Save Folder” button at the top
right, then choose the desired output directory from the directory chooser.

Q/C Processing
The desired output products are chosen using the checkboxes in the bar on the
left side of the BatchAspen window. An output file of each selected type will be
created for each input file.

To begin the processing, press the “Process” (!) button or select File > Process.
BatchAspen will begin processing each file, starting at the beginning of the list. A
status indicator appears next to each file. The status indicator is gray before a file
is processed, yellow while a file is being processed, green if a file has been
processed successfully, and orange if it had processing errors.

When processing is underway, the “Process” button changes to a “Stop” button,
which can stop processing before the end of the list has been reached.

Q/C Parameters
BatchAspen uses the same configuration scheme as Aspen, which is documented
fully in the Configuration section (page 36). As with Aspen, activating the File-
>Configure… menu item will display the configuration management interface.

The configuration set that is designated as active is used by
both Aspen and BatchAspen.
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Commandline Aspen
Aspen-QC is a version of Aspen that performs the Q/C and message coding

functions, but does not provide a graphical user interface. Therefore, it can be run
from shell scripts or the command line, to process a sounding data file in a
standalone mode. The same Q/C and coding algorithms used in Aspen are
incorporated into Aspen-QC .

The Aspen-QC executable is provided in the Aspen distribution for all operating
systems.

On Mac OSX, an additional script, run_aspenqc , is provided.
This script sets up the appropriate library paths, then runs
Aspen-QC . Supply command line arguments to this script the
same way as you would to Aspen-QC directly.

Aspen-QC uses the same XML configuration file as Aspen (aspen.xml and
aspen.dtd), located in the user’s config directory. If the configuration directory is
not set up, then it will search the current working directory for these files. If the
files are not found, then a built-in configuration will be used. It is not
recommended to use the built-in configuration.

Be sure to examine aspen.xml to verify that the desired
configuration set is specified as the current set. Alternatively, a
good practice is to always specify the desired configuration
set via the command line switch.

Switches
Command line switches control the processing and output products from
AspenQC:

Commandline Aspen PDF last updated: June 06, 2025

Atmospheric Sounding Processing ENvironment (ASPEN) User Manual Page 70



Options:
-i [ --input ] [=arg(=stdin)]   sounding data file
-l [ --eol ] [=arg(=stdout)]    create eol
-f [ --frd ] [=arg(=stdout)]    create frd
-e [ --csv ] [=arg(=stdout)]    create csv
-c [ --class ] [=arg(=stdout)]  create class
-w [ --wmo ] [=arg(=stdout)]    create wmo
-n [ --netcdf ] [=arg(=stdout)] create netcdf
-g [ --svg ] [=arg(=stdout)]    create skewt svg file
-b [ --bufr ] [=arg(=stdout)]   create BUFR file
-d [ --dims ] arg               skewt dimensions pmin:pmax:tm

in:tmax
-q [ --qc ] [=arg(=none)]       Override QC mode: normal, pas

s, tddrybias
-v [ --verbose ]                verbose enabled
-s [ --config ] arg             override active config set1 (ob

solete)
-1 [ --config1 ] arg            override active config set1
-2 [ --config2 ] arg            override active config set2
-o [ --options ] arg            override config options opt1=v

al:opt2=val:...
-x [ --sfcaltitude ] arg        sounding sfc alt (m) for upwa

rd integration
-h [ --help ]                   help

• i – the name of the input data file. The file type will be automatically
determined, and can be any of the file types that Aspen can read. If this
parameter is missing, the data are read from standard input.

• l , f , e , c , w , n , g , b – Generate an output file of the specified file
type. The output specifiers can take an optional file name, to which the
data will be written. If not provided, the output products will be written to
standard output.

• d – Specify limits for the Skew-T SVG image, in the format
pmin:pmax:tmin:tmax. The fields are pmin: minimum pressure (mb),
pmax: maximum pressure(mb), tmin: minimum temperature (C), tmax:
maximum temperature (C). Skew-T diagrams can produce odd results for
arbitrary plotting limits, and some experimentation will be necessary to
determine appropriate values for the limits.

• q - Override the QC mode. QC modes that can be specified are normal
(all Aspen processing applied), tddrybias (only the temperature-
dependent dry bias correction applied), or pass (passthrough mode,
output products are generated but no quality control is applied to the
data)
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• v – Print (verbose) status messages as the processing proceeds.

• s , 1 , 2 – Specify a config set name to override the config set
designated as active in the Aspen XML. The second config set option is
for processing the descending leg of radiosonde data.

• o - Set the value for one or more config attributes. See the Configuration
Parameters (page 49) section for a list of all configuration set attributes.
(Boolean config item values must be given as 0 or 1, not ‘true’ or ‘false’.)

• x - Override the surface altitude used for upward integration.

• h – Print out the usage statement.

An example of an AspenQC usage would be:

AspenQC –i classData.dat –e classData.csv -s editsonde –g skewt.svg

This ingests a CLASS file and creates skew-T and CSV output using the editsonde
config set.
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Input File Formats
Aspen can ingest sounding data that is provided in the following file formats.

Note that the file formats are not complete; i.e one format will
contain information that another format does not support.
Metadata in particular is not consistent between file formats.

Warning: Aspen automatically detects the format of the file
that it opens, and assumes that the sounding contained is
from the associated instrument. This can lead to ambiguities, if
Aspen is used to process a file that it has written. For
instance, if dropsonde data are saved by Aspen in “CLASS”
format, and then this file is used as input to Aspen, the
program will assume that the data are from an upsonde
sounding, rather than a dropsonde. This can lead to
erroneous results within Aspen, since the characteristics of the
sounding system affect the processing procedures. In
addition, care should be taken not to process data twice when
using formats Aspen can both read and write.

NCAR AVAPS GPS Dropsonde “D” files
The AVAPS D file includes metadata in header and footer lines, with a variable
number of data lines in between. Line contents are determined from an identifier
at the beginning of the line: “S” lines for sounding data, “P” for pre-launch data,
“A” for launch observation, and “COM” and other identifiers for metadata. Data
lines are arranged in fixed width columns, with a standard set of data parameters
reported. Header lines above the data lines give the column contents and units,
and footer lines below the data lines give additional metadata about the sounding.

The data is reported in time order for both upsondes and dropsondes.
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NCAR GAUS Upsonde files
The GAUS file includes metadata in header and footer lines, with a variable
number of data lines in between. Line contents are determined from an identifier
at the beginning of the line: “S” lines for sounding data, “P” for pre-launch data,
“A” for launch observation, and “COM” and other identifiers for metadata. Data
lines are arranged in fixed width columns, with a standard set of data parameters
reported. Header lines above the data lines give the column contents and units,
and footer lines below the data lines give additional metadata about the sounding.

The data is reported in time order for both upsondes and dropsondes.

NCAR MCASS Upsonde files
The MCASS file includes metadata in header and footer lines, with a variable
number of data lines in between. Line contents are determined from an identifier
at the beginning of the line: “S” lines for sounding data, “P” for pre-launch data,
“A” for launch observation, and “COM” and other identifiers for metadata. Data
lines are arranged in fixed width columns, with a standard set of data parameters
reported. Header lines above the data lines give the column contents and units,
and footer lines below the data lines give additional metadata about the sounding.

The data is reported in time order for both upsondes and dropsondes.

NCAR CLASS Upsonde files
The CLASS file starts with a 15 line header section, followed by a variable number
of data lines. The data lines are arranged in fixed width columns. A mandatory set
of 21 data parameters is reported, even though a number of these (specifically the
“quality” values) are always marked with a missing value indicator.

The data is reported in the sequence of decreasing pressure, i.e. from the surface
upward, regardless of the direction of the sounding.

NCAR GLASS Upsonde files
The GLASS file starts with a 15 line header section, followed by a variable number
of data lines. The data lines are arranged in fixed width columns. A mandatory set
of 10 data parameters is reported.

The data is reported in the sequence of decreasing pressure, i.e. from the surface
upward, regardless of the direction of the sounding.
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Comma Separated Values (CSV)
The “Comma Separated Value” file format is used for data interchange between
Aspen and other software. This is the recommended file format for users who are
importing data from an instrument that doesn’t produce other specific input file
types. It is a free form structure, with one data record per line, and the fields in a
record separated by commas. A CSV file can be read directly into Microsoft Excel,
and the data will be correctly organized in the spreadsheet.

For input to Aspen, certain conventions must be followed within the CSV file. Each
line begins with an identifier, followed by one or more fields. The order of the lines
is generally not important, within the following guidelines:

• The first line must be:

FileFormat,CSV

• After the first line, the launch time must be provided on lines as follows:

Year,2001
Month,08
Day,01
Hour,17
Minute,58
Second,34

• The launch observation data or other metadata may be optionally
provided in lines labeled with the parameter name (case-insensitive) from
the list of examples below:
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latitude,17.42451,"units=deg"
longitude,126.50004,"units=deg"
pressure,1002.6,"units=hPa"
temperature,28.6,"units=deg C"
rh,82.7,"units=%"
speed,7.5,"units=m/s"
direction,261.4,"units=deg"
altitude,15.5,"units=m"
gpsaltitude,15.5,"units=m"
comments,"180 sec,  4-8 sat, eye drop,"
datatype,"AVAPS SOUNDING DATA, Channel 2"
equipmenttype,"8"
platformtype,"WC 130"
platformid,"65-0963"
project,"RAINEX"
flight,"RF04"
agency,"NCAR"
ptuwindtimediff,"-0.06"
radiationcorr,"0"
trackingtype,"08"
sondeid,"980730027"
sondetype,""
operator,"Nick"
soundingdescription,"D20000609_220604.1 345327 STEPS 200
0 june 9 flt1"
launchobssource,"IWGADTS Format (IWG1)"
launchobstime,"07:11:24"
sondemodel,"RS904"
launchsite,"R/V Tommy Thompson"
thermosensor,"Vaisala RSS904"

• To designate a dropsonde sounding, include a line:

Ascending,"false"

• A “Fields” line defines the data fields and their order, for the succeeding
“Data” lines. For an input CSV file to be read properly by Aspen, the
following data field names (case-insensitive) must be used:

Fields Aspen utilization
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time
pressure

Required input data fields

temp
rh
rh1
rh2
speed
direction
latitude
longitude
altitude
ascent
sats
gpsalt

These data fields will be utilized if
provided

others Other data fields in input will be
ignored

• The “Units” lines documents the units of each data field. Note that the
units shown here must be adhered to; Aspen will not make units
conversions. At least the time and pressure fields must be provided:

Units,sec,mb,deg C,%,m/s,deg,deg,deg,m,deg C,m/s,m/s,m/s

• The “Data” lines follow after all of the preceding records.

Some other rules apply:

• Long strings should be enclosed in quotes.

• Don’t include commas in strings

• Capitalization is not important.

• The data series must be ordered in time

• Time tags less than zero will be ignored
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• Don’t use reserved strings in the first field of a line.

• “Fields” must come before “Data”

• Missing data are simply represented by empty fields, i.e. two commas in
succession, or a trailing comma on the end of a line, indicating that the
last field is missing.

The following demonstrates a small CSV file:

FileFormat,CSV
Year,2001
Month,08
Day,01
Hour,17
Minute,58
Second,34
Pressure,57.6,"units=mb"
Temperature,-59.9,"units=deg C"
RH,,"units=%"
Speed,7.9,"units=m/s"
Direction,92.0,"units=deg"
Latitude,30.9909,"units=deg"
Longitude,-119.5005,"units=deg"
Altitude,19610.0,"units=m"
Ascending,"false"
Fields,Time,Pressure,Temperature,RH,Speed,Direction,Latitude,Lo
ngitude,Altitude,Dewpoint,Uwnd,Vwnd,Ascent
Units,sec,mb,deg C,%,m/s,deg,deg,deg,m,deg C,m/s,m/s,m/s
Data,0.3,,,,,,,,,,,,
Data,0.8,,,,,,,,,,,,
Data,11.8,,,,11.52,69.53,,,,,-10.79,-4.03,
Data,38.8,71.06,-60.33,,8.23,104.25,30.99129,-119.50375,1829
5.7,,-7.98,2.03,-39.94
Data,51.8,77.01,-63.75,,8.67,160.11,30.99174,-119.50441,1779
9.7,,-2.95,8.15,-36.35
Data,66.3,83.86,-62.29,,,,30.99267,-119.50520,17276.1,,,,-35.06
Data,75.8,88.52,-64.99,,8.95,119.15,30.99295,-119.50592,1694
4.3,,-7.82,4.36,-34.01
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Vaisala MW41 Upsonde files
Aspen can read in ASCII text files from the MW41 radiosonde system, but will not
apply quality control procedures as this is done by the MW41 software and should
not be duplicated. The use case for this is using Aspen to convert from MW41
format to other more widely used formats for sounding data.

WMO TEMP messages
Aspen can extract levels information from a WMO TEMP message. Aspen will not
attempt to apply QC to a WMO message, but the data it contains can be
examined in the Levels tab or plotted in the XY Graph or Skew-T tabs. In this case
Aspen is used for data visualization rather than data processing.
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Output File Formats
Note that the file formats are not complete; i.e one format will
contain information that another format does not support.
Thus, the CSV and netCDF formats can document the
configuration parameters used in the processing, whereas the
CLASS format does not support inclusion of this information.

Data product File output formats

Raw data CLASS
EOL
CSV
netCDF

QC data CLASS
EOL
FRD
CSV
netCDF
BUFR (subset of levels
data merged in)

XY graph image PNG
JPG
PDF
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Skew-T image PNG
JPG
SVG

Levels data CSV

WMO TEMP
message

ASCII text

Summary
information

PDF

NCAR CLASS upsonde files
The CLASS file starts with a 15 line header section, followed by a variable number
of data lines. The data lines are arranged in fixed width columns. A mandatory set
of 21 data parameters is reported, though a number of these (specifically the
“quality” values) are always marked with a missing value indicator.

The data is reported in the sequence of decreasing pressure, i.e. from the surface
upward, regardless of the direction of the sounding.

NCAR EOL dropsonde files
The EOL file starts with a 15 line header section, followed by a variable number of
data lines. The data lines are arranged in fixed width columns. A fixed set of 17
data parameters is reported. The data is reported in the sequence of decreasing
pressure, i.e. from the surface upward, regardless of the direction of the sounding.

More information about the EOL format is available on the EOL website
(https://www.eol.ucar.edu/system/files/
v4.EOL%20Sounding%20Data%20File%20Format_0.pdf)
.
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NOAA HRD FRD dropsonde files
The FRD file starts with a 21 line header section, followed by a variable number of
data lines. The data lines are arranged in fixed width columns. A fixed set of 18
parameters is reported, though a number of these are always set to zeros. More
information on FRD file format can be found in the HRD README
(https://www.aoml.noaa.gov/hrd/Storm_pages/sondeREADME.pdf).

The data is reported in the sequence of increasing time for both up and drop
soundings.

Comma Separated Values (CSV)
The “Comma Separated Value” file format is used for data interchange between
Aspen and other software. It is a free form structure, with one data record per line,
and the fields in a record separated by commas. A CSV file can be read directly
into Microsoft Excel, and the data will be correctly organized in the spreadsheet.
See the Input File Formats section (page 73) for more information on how Aspen
CSV file are formatted.

Levels data is also provided in CSV format, where the file contains the data from
the table in the Levels tab.

NetCDF files
Network Common Data Form (netCDF) (https://www.unidata.ucar.edu/software/netcdf/)
is a binary, array-based, self-describing data format that is commonly used for
earth science data. Sounding data is stored in a series for each variable, indexed
by time. Metadata is stored as attributes of either specific variables or the entire
file. When possible, Aspen netCDF output is compliant with the Climate and
Forecast (CF) Conventions (http://cfconventions.org/) for file structure and metadata.

In-depth documentation of Aspen netCDF output is available on the EOL website
for radiosondes
(https://www.eol.ucar.edu/sites/default/files/files_live/private/
NCAR_EOL_ISF_radiosonde_NetCDF_data_files_0.pdf)
and dropsondes
(https://www.eol.ucar.edu/sites/default/files/files_live/private/
NCAR_EOL_ISF_dropsonde_NetCDF_data_files_4.pdf)
.

Output File Formats PDF last updated: June 06, 2025

Atmospheric Sounding Processing ENvironment (ASPEN) User Manual Page 82

https://www.aoml.noaa.gov/hrd/Storm_pages/sondeREADME.pdf
https://www.aoml.noaa.gov/hrd/Storm_pages/sondeREADME.pdf
https://www.aoml.noaa.gov/hrd/Storm_pages/sondeREADME.pdf
https://www.unidata.ucar.edu/software/netcdf/
https://www.unidata.ucar.edu/software/netcdf/
http://cfconventions.org/
http://cfconventions.org/
http://cfconventions.org/
https://www.eol.ucar.edu/sites/default/files/files_live/private/NCAR_EOL_ISF_radiosonde_NetCDF_data_files_0.pdf
https://www.eol.ucar.edu/sites/default/files/files_live/private/NCAR_EOL_ISF_radiosonde_NetCDF_data_files_0.pdf
https://www.eol.ucar.edu/sites/default/files/files_live/private/NCAR_EOL_ISF_radiosonde_NetCDF_data_files_0.pdf
https://www.eol.ucar.edu/sites/default/files/files_live/private/NCAR_EOL_ISF_dropsonde_NetCDF_data_files_4.pdf
https://www.eol.ucar.edu/sites/default/files/files_live/private/NCAR_EOL_ISF_dropsonde_NetCDF_data_files_4.pdf
https://www.eol.ucar.edu/sites/default/files/files_live/private/NCAR_EOL_ISF_dropsonde_NetCDF_data_files_4.pdf


WMO BUFR files
BUFR messages report both one-second averages of the entire quality controlled
sounding profile and the contents of the calculated levels. BUFR files use a binary
format specified by the World Meteorological Organization’s Manual on Codes (no.
306) (https://www.wmo.int/pages/prog/www/WMOCodes/ManualonCodes.html). Aspen
codes sounding data as B/C25 (binary equivalent of TEMP, TEMP SHIP, or TEMP
MOBIL) or B/C26 (binary equivalent of TEMP DROP), depending on the sounding
file.

Averaging for BUFR output

Since B/C25 and B/C26 formats are currently limited to 1-second resolution, full
resolution dropsonde data must be averaged down to 1Hz. The averaging
algorithm calculates the mean of all valid data points in each one-second bin,
using U and V component averaging for winds before converting back to speed
and direction.

WMO TEMP files
TEMP messages report specially encoded levels data in ASCII text. The contents
and formatting of TEMP messages is determined by the World Meteorological
Organization’s Manual on Codes (no. 306)
(https://www.wmo.int/pages/prog/www/WMOCodes/ManualonCodes.html). Aspen
codes sounding data as TEMP (FM35), TEMP SHIP (FM36), TEMP DROP (FM 37),
or TEMP MOBIL (FM 38) depending on the sounding file.

Graphics files
Aspen can save graphics products in several file formats. SVG and PNG format
are higher resolution than JPG and therefore preferred.

NASA ICARTT files
The ICARTT (https://www-air.larc.nasa.gov/missions/etc/IcarttDataFormat.htm) data
format is used by NASA for dropsonde and other airborne atmospheric data. It is
an ASCII format with a metadata header followed by data.
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Aspen does not produce ICARTT files natively, however, Sean Freeman at CSU
has written a Python converter from Aspen netCDF to ICARTT. Please contact the
aspen mailing list if you would like a copy of the conversion code.
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